Pythonですが、バージョン選びに問題があるらしい。

2.X系と西暦3000年のPythonとして登場した(なにそれ?)3.X系があるらしい。 3.X系には下位互換がいまいち不十分らしいです。 しかし、これからしばらくは互換問題に関わることも多そうなので、2.X系をひと通り覚えてから3.X系に進もうと思います。